Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/mattermost/mattermost-plugin-confluence
  4. ›
  5. CVE-2025-53514

CVE-2025-53514: Mattermost Confluence Plugin has Improper Check for Unusual or Exceptional Conditions

August 11, 2025

Mattermost Confluence Plugin versions < 1.5.0 fail to handle unexpected request bodies, allow\ing attackers to crash the plugin via constant hits to the server webhook endpoint with an invalid request body.

References

  • github.com/advisories/GHSA-w92j-c6gr-hj8r
  • github.com/mattermost/mattermost-plugin-confluence
  • mattermost.com/security-updates
  • nvd.nist.gov/vuln/detail/CVE-2025-53514

Code Behaviors & Features

Detect and mitigate CVE-2025-53514 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.5.0

Fixed versions

  • 1.5.0

Solution

Upgrade to version 1.5.0 or above.

Impact 5.9 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-754: Improper Check for Unusual or Exceptional Conditions

Source file

go/github.com/mattermost/mattermost-plugin-confluence/CVE-2025-53514.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:23 +0000.