Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/kubernetes-csi/csi-proxy/v2
  4. ›
  5. CVE-2023-3893

CVE-2023-3893: Kubernetes csi-proxy vulnerable to privilege escalation due to improper input validation

November 3, 2023 (updated July 9, 2025)

Kubernetes is vulnerable to privilege escalation when a user that can create pods on Windows nodes running kubernetes-csi-proxy may be able to escalate to admin privileges on those nodes. Kubernetes clusters are only affected if they include Windows nodes running kubernetes-csi-proxy.

References

  • github.com/advisories/GHSA-r6cc-7wj7-gfx2
  • github.com/kubernetes-csi/csi-proxy
  • github.com/kubernetes-csi/csi-proxy/commit/0e83a68159111e4ee510f5aa56d47ba97bda60c7
  • github.com/kubernetes-csi/csi-proxy/commit/2523e6674dedf3de27f84235efec28555da24664
  • github.com/kubernetes/kubernetes/issues/119594
  • groups.google.com/g/kubernetes-security-announce/c/lWksE2BoCyQ
  • nvd.nist.gov/vuln/detail/CVE-2023-3893
  • security.netapp.com/advisory/ntap-20231221-0004

Code Behaviors & Features

Detect and mitigate CVE-2023-3893 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.0.0-alpha.0 before 2.0.0-alpha.1, version 2.0.0-alpha.0

Fixed versions

  • 2.0.0-alpha.1

Solution

Upgrade to version 2.0.0-alpha.1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

go/github.com/kubernetes-csi/csi-proxy/v2/CVE-2023-3893.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:24 +0000.