Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/heroiclabs/nakama
  4. ›
  5. CVE-2022-2306

CVE-2022-2306: Insufficient Session Expiration

July 6, 2022 (updated July 15, 2022)

Old session tokens can be used to authenticate to the application and send authenticated requests.

References

  • github.com/advisories/GHSA-xv59-gc3r-rf92
  • github.com/heroiclabs/nakama/commit/ce8d3921e2acd44ef8b5e6edfe595b6df067b166
  • huntr.dev/bounties/35acf263-6db4-4310-ab27-4c3c3a53f796
  • nvd.nist.gov/vuln/detail/CVE-2022-2306

Code Behaviors & Features

Detect and mitigate CVE-2022-2306 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before v3.13.0

Fixed versions

  • v3.13.0

Solution

Upgrade to version 3.13.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-613: Insufficient Session Expiration

Source file

go/github.com/heroiclabs/nakama/CVE-2022-2306.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:44 +0000.