Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/gravitl/netmaker
  4. ›
  5. CVE-2022-36110

CVE-2022-36110: Incorrect Authorization

September 15, 2022

Netmaker makes networks with WireGuard. Prior to version 0.15.1, Improper Authorization functions lead to non-privileged users running privileged API calls. If someone adds users to the Netmaker platform who do not have admin privileges, they can use their auth tokens to run admin-level functions via the API. This problem has been patched in v0.15.1.

References

  • github.com/advisories/GHSA-ggf6-638m-vqmg
  • github.com/gravitl/netmaker/releases/tag/v0.15.1
  • github.com/gravitl/netmaker/security/advisories/GHSA-ggf6-638m-vqmg
  • nvd.nist.gov/vuln/detail/CVE-2022-36110

Code Behaviors & Features

Detect and mitigate CVE-2022-36110 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.15.1

Fixed versions

  • v0.15.1

Solution

Upgrade to version 0.15.1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

go/github.com/gravitl/netmaker/CVE-2022-36110.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.