Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/elastic/beats
  4. ›
  5. CVE-2017-11480

CVE-2017-11480: Denial of Service in Packetbeat

February 15, 2022 (updated February 14, 2023)

Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.

References

  • discuss.elastic.co/t/beats-5-6-4-security-update/106739
  • github.com/advisories/GHSA-9q3g-m353-cp4p
  • github.com/elastic/beats/commit/aeca65779d573976981587ca1d1461399e1b59dd
  • github.com/elastic/beats/pull/5457
  • github.com/elastic/beats/pull/5479
  • github.com/elastic/beats/pull/5480
  • nvd.nist.gov/vuln/detail/CVE-2017-11480
  • pkg.go.dev/vuln/GO-2022-0643

Code Behaviors & Features

Detect and mitigate CVE-2017-11480 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.6.4, all versions starting from 6.0.0-alpha1 before 6.0.0

Fixed versions

  • v5.6.4
  • v6.0.0

Solution

Upgrade to versions 5.6.4, 6.0.0 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Source file

go/github.com/elastic/beats/CVE-2017-11480.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:51 +0000.