Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/consensys/gnark
  4. ›
  5. CVE-2025-57801

CVE-2025-57801: gnark is vulnerable to signature malleability in EdDSA and ECDSA due to missing scalar checks

August 22, 2025 (updated January 22, 2026)

In version before, sig.s used without asserting 0 ≤ S < order in Verify function in eddsa.go and ecdsa.go, which will lead to signature malleability vulnerability.

References

  • github.com/Consensys/gnark
  • github.com/Consensys/gnark/commit/0ba6730f05537a351517998add89a61a0d82716e
  • github.com/Consensys/gnark/security/advisories/GHSA-95v9-hv42-pwrj
  • github.com/advisories/GHSA-95v9-hv42-pwrj
  • nvd.nist.gov/vuln/detail/CVE-2025-57801
  • pkg.go.dev/vuln/GO-2025-3912

Code Behaviors & Features

Detect and mitigate CVE-2025-57801 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.14.0

Fixed versions

  • 0.14.0

Solution

Upgrade to version 0.14.0 or above.

Impact 9.1 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-347: Improper Verification of Cryptographic Signature

Source file

go/github.com/consensys/gnark/CVE-2025-57801.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:49 +0000.