Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/charmbracelet/soft-serve
  4. ›
  5. CVE-2025-22130

CVE-2025-22130: Soft Serve vulnerable to path traversal attacks

January 8, 2025 (updated October 31, 2025)

Path traversal attack gives access to existing non-admin users to access and take over other user’s repositories. A malicious user then can modify, delete, and arbitrarily repositories as if they were an admin user without explicitly giving them permissions.

References

  • github.com/advisories/GHSA-j4jw-m6xr-fv6c
  • github.com/charmbracelet/soft-serve
  • github.com/charmbracelet/soft-serve/commit/a8d1bf3f9349c138383b65079b7b8ad97fff78f4
  • github.com/charmbracelet/soft-serve/releases/tag/v0.8.2
  • github.com/charmbracelet/soft-serve/security/advisories/GHSA-j4jw-m6xr-fv6c
  • nvd.nist.gov/vuln/detail/CVE-2025-22130

Code Behaviors & Features

Detect and mitigate CVE-2025-22130 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.8.2

Fixed versions

  • 0.8.2

Solution

Upgrade to version 0.8.2 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Source file

go/github.com/charmbracelet/soft-serve/CVE-2025-22130.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:28 +0000.