Advisory Database
  • Advisories
  • Dependency Scanning
  1. golang
  2. ›
  3. github.com/canonical/lxd
  4. ›
  5. CVE-2025-54286

CVE-2025-54286: Canonical LXD CSRF Vulnerability When Using Client Certificate Authentication with the LXD-UI

October 2, 2025 (updated November 5, 2025)

OIDC authentication uses cookies with the SameSite=Strict attribute, preventing cookies from being sent with requests from other sites. Therefore, CSRF does not occur as long as web services in a Same Site relationship (same eTLD+1) with the origin running LXD-UI are trusted.

However, since the SameSite concept does not apply to client certificates, CSRF protection that doesn’t rely on the SameSite attribute is necessary.

Note that when using cross-origin fetch API, client certificates are not sent in no-cors mode due to CORS restrictions (according to the WHATWG Fetch specification(https://fetch.spec.whatwg.org/#credentials), client certificates are treated as credentials), making cross-site attacks using fetch API difficult unless CORS settings are vulnerable. However, since LXD’s API parses request bodies as JSON even when Content-Type is text/plain or application/x-www-form-urlencoded, CSRF attacks exploiting HTML form submissions are possible.

References

  • github.com/advisories/GHSA-p8hw-rfjg-689h
  • github.com/canonical/lxd
  • github.com/canonical/lxd/security/advisories/GHSA-p8hw-rfjg-689h
  • nvd.nist.gov/vuln/detail/CVE-2025-54286
  • pkg.go.dev/vuln/GO-2025-4003

Code Behaviors & Features

Detect and mitigate CVE-2025-54286 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 5.0 before 5.0.5, all versions starting from 5.1 before 5.21.4, all versions starting from 6.0 before 6.5

Fixed versions

  • 5.0.5
  • 5.21.4
  • 6.5

Solution

Upgrade to versions 5.0.5, 5.21.4, 6.5 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

go/github.com/canonical/lxd/CVE-2025-54286.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:29 +0000.