Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. trestle-auth
  4. ›
  5. CVE-2021-29435

CVE-2021-29435: Cross-Site Request Forgery (CSRF)

April 13, 2021 (updated April 19, 2021)

trestle-auth is an authentication plugin for the Trestle admin framework. A vulnerability in trestle-auth allows an attacker to create a form that will bypass Rails’ built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-29435

Code Behaviors & Features

Detect and mitigate CVE-2021-29435 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.4.0 up to 0.4.1

Fixed versions

  • 0.4.2

Solution

Upgrade to version 0.4.2 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

gem/trestle-auth/CVE-2021-29435.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:54 +0000.