Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. sorcery
  4. ›
  5. CVE-2020-11052

CVE-2020-11052: Improper Restriction of Excessive Authentication Attempts

May 7, 2020 (updated May 13, 2020)

In Sorcery, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout.

References

  • nvd.nist.gov/vuln/detail/CVE-2020-11052

Code Behaviors & Features

Detect and mitigate CVE-2020-11052 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.15.0

Fixed versions

  • 0.15.0

Solution

Upgrade to version 0.15.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-307: Improper Restriction of Excessive Authentication Attempts

Source file

gem/sorcery/CVE-2020-11052.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:20 +0000.