Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. smashing
  4. ›
  5. CVE-2021-35440

CVE-2021-35440: Cross-site Scripting

July 6, 2021 (updated July 7, 2021)

Smashing is vulnerable to Cross Site Scripting (XSS). A URL for a widget can be crafted and used to execute JavaScript on the victim’s computer. The JavaScript code can then steal data available in the session/cookies depending on the user environment (e.g. if re-using internal URL’s for deploying, or cookies that are very permissive) private information may be retrieved by the attacker.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-35440

Code Behaviors & Features

Detect and mitigate CVE-2021-35440 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 1.3.4

Fixed versions

  • 1.3.5

Solution

Upgrade to version 1.3.5 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

gem/smashing/CVE-2021-35440.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:19 +0000.