Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. rubygems-update
  4. ›
  5. CVE-2019-8324

CVE-2019-8324: Improper Input Validation

June 17, 2019 (updated July 21, 2019)

A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is evaluated by ensure_loadable_spec during the pre-installation check.

References

  • nvd.nist.gov/vuln/detail/CVE-2019-8324

Code Behaviors & Features

Detect and mitigate CVE-2019-8324 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.6.0 up to 3.0.2

Fixed versions

  • 3.0.3

Solution

Upgrade to version 3.0.3 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

gem/rubygems-update/CVE-2019-8324.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:45 +0000.