Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. rubygems-update
  4. ›
  5. CVE-2018-1000077

CVE-2018-1000077: Improper Input Validation

March 13, 2018 (updated May 20, 2019)

RubyGems contains an Improper Input Validation vulnerability in ruby gems specification homepage attribute that can result in a malicious gem being able to set an invalid homepage URL.

References

  • blog.rubygems.org/2018/02/15/2.7.6-released.html
  • nvd.nist.gov/vuln/detail/CVE-2018-1000077

Code Behaviors & Features

Detect and mitigate CVE-2018-1000077 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions after 2.2.9 up to 2.5.0

Fixed versions

  • 2.5.1

Solution

Upgrade to version 2.5.1 or above.

Impact 5.3 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

gem/rubygems-update/CVE-2018-1000077.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:53 +0000.