Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. rubygems-update
  4. ›
  5. CVE-2017-0903

CVE-2017-0903: Deserialization of Untrusted Data

October 11, 2017 (updated October 9, 2019)

rubygems-update is vulnerable to a remote code execution vulnerability. YAML deserialization of gem specifications can bypass class white lists. Specially crafted serialized objects can possibly be used to escalate to remote code execution.

References

  • blog.rubygems.org/2017/10/09/2.6.14-released.html
  • blog.rubygems.org/2017/10/09/unsafe-object-deserialization-vulnerability.html
  • www.securityfocus.com/bid/101275
  • nvd.nist.gov/vuln/detail/CVE-2017-0903

Code Behaviors & Features

Detect and mitigate CVE-2017-0903 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.0.0 up to 2.6.13

Fixed versions

  • 2.6.14

Solution

Upgrade to version 2.6.14 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data

Source file

gem/rubygems-update/CVE-2017-0903.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:17 +0000.