Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. rubygems-update
  4. ›
  5. CVE-2017-0902

CVE-2017-0902: Origin Validation Error

August 31, 2017 (updated October 9, 2019)

RubyGems is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.

References

  • blog.rubygems.org/2017/08/27/2.6.13-released.html
  • www.securityfocus.com/bid/100586
  • www.securitytracker.com/id/1039249
  • hackerone.com/reports/218088
  • nvd.nist.gov/vuln/detail/CVE-2017-0902

Code Behaviors & Features

Detect and mitigate CVE-2017-0902 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 2.6.12

Fixed versions

  • 2.6.13

Solution

Upgrade to version 2.6.13 or above.

Impact 8.1 HIGH

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-346: Origin Validation Error

Source file

gem/rubygems-update/CVE-2017-0902.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:41 +0000.