Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. rubygems-update
  4. ›
  5. CVE-2017-0899

CVE-2017-0899: Code Injection

August 31, 2017 (updated October 9, 2019)

RubyGems is vulnerable to maliciously crafted gem specifications that include terminal escape characters. Printing the gem specification would execute terminal escape sequences.

References

  • blog.rubygems.org/2017/08/27/2.6.13-released.html
  • www.securityfocus.com/bid/100576
  • www.securitytracker.com/id/1039249
  • nvd.nist.gov/vuln/detail/CVE-2017-0899

Code Behaviors & Features

Detect and mitigate CVE-2017-0899 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 2.6.12

Fixed versions

  • 2.6.13

Solution

Upgrade to version 2.6.13 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

gem/rubygems-update/CVE-2017-0899.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:10 +0000.