Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. ruby-saml
  4. ›
  5. CVE-2025-25293

CVE-2025-25293: Ruby SAML allows remote Denial of Service (DoS) with compressed SAML responses

March 12, 2025 (updated November 3, 2025)

ruby-saml is susceptible to remote Denial of Service (DoS) with compressed SAML responses.

Ruby-saml uses zlib to decompress SAML responses in case they’re compressed. It is possible to bypass the message size check with a compressed assertion since the message size is checked before inflation and not after.

References

  • about.gitlab.com/releases/2025/03/12/patch-release-gitlab-17-9-2-released
  • github.blog/security/sign-in-as-anyone-bypassing-saml-sso-authentication-with-parser-differentials
  • github.com/SAML-Toolkits/ruby-saml
  • github.com/SAML-Toolkits/ruby-saml/commit/acac9e9cc0b9a507882c614f25d41f8b47be349a
  • github.com/SAML-Toolkits/ruby-saml/commit/e2da4c6dae7dc01a4d9cd221395140a67e2b3eb1
  • github.com/SAML-Toolkits/ruby-saml/releases/tag/v1.12.4
  • github.com/SAML-Toolkits/ruby-saml/releases/tag/v1.18.0
  • github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-92rq-c8cf-prrq
  • github.com/advisories/GHSA-92rq-c8cf-prrq
  • github.com/omniauth/omniauth-saml/security/advisories/GHSA-hw46-3hmr-x9xv
  • github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/CVE-2025-25293.yml
  • lists.debian.org/debian-lts-announce/2025/04/msg00011.html
  • nvd.nist.gov/vuln/detail/CVE-2025-25293
  • security.netapp.com/advisory/ntap-20250314-0008
  • securitylab.github.com/advisories/GHSL-2024-355_ruby-saml

Code Behaviors & Features

Detect and mitigate CVE-2025-25293 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.12.4, all versions starting from 1.13.0 before 1.18.0

Fixed versions

  • 1.12.4
  • 1.18.0

Solution

Upgrade to versions 1.12.4, 1.18.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-400: Uncontrolled Resource Consumption
  • CWE-770: Allocation of Resources Without Limits or Throttling

Source file

gem/ruby-saml/CVE-2025-25293.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:13 +0000.