Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. ruby-saml
  4. ›
  5. CVE-2024-45409

CVE-2024-45409: SAML authentication bypass via Incorrect XPath selector

September 10, 2024 (updated September 20, 2024)

Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system.

This vulnerability was reported by ahacker1 of SecureSAML (ahacker1@securesaml.com)

References

  • github.com/SAML-Toolkits/ruby-saml
  • github.com/SAML-Toolkits/ruby-saml/commit/1ec5392bc506fe43a02dbb66b68741051c5ffeae
  • github.com/SAML-Toolkits/ruby-saml/commit/4865d030cae9705ee5cdb12415c654c634093ae7
  • github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-jw9c-mfg7-9rx2
  • github.com/advisories/GHSA-jw9c-mfg7-9rx2
  • github.com/omniauth/omniauth-saml/commit/4274e9d57e65f2dcaae4aa3b2accf831494f2ddd
  • github.com/omniauth/omniauth-saml/security/advisories/GHSA-cvp8-5r8g-fhvq
  • github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth-saml/CVE-2024-45409.yml
  • github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth-saml/GHSA-cvp8-5r8g-fhvq.yml
  • github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/CVE-2024-45409.yml
  • nvd.nist.gov/vuln/detail/CVE-2024-45409

Code Behaviors & Features

Detect and mitigate CVE-2024-45409 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.12.3, all versions starting from 1.13.0 before 1.17.0

Fixed versions

  • 1.12.3
  • 1.17.0

Solution

Upgrade to versions 1.12.3, 1.17.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-347: Improper Verification of Cryptographic Signature

Source file

gem/ruby-saml/CVE-2024-45409.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.