Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. ruby-saml
  4. ›
  5. CVE-2015-20108

CVE-2015-20108: ruby-saml vulnerable to XPath injection

May 27, 2023 (updated January 14, 2025)

xml_security.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used.

References

  • github.com/SAML-Toolkits/ruby-saml
  • github.com/SAML-Toolkits/ruby-saml/commit/9853651b96b99653ea8627d757d46bfe62ab6448
  • github.com/SAML-Toolkits/ruby-saml/compare/v0.9.2...v1.0.0
  • github.com/SAML-Toolkits/ruby-saml/pull/225
  • github.com/advisories/GHSA-r364-2pj4-pf7f
  • github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/CVE-2015-20108.yml
  • github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/OSVDB-124991.yml
  • nvd.nist.gov/vuln/detail/CVE-2015-20108
  • security.netapp.com/advisory/ntap-20230703-0003
  • security.snyk.io/vuln/SNYK-RUBY-RUBYSAML-20217

Code Behaviors & Features

Detect and mitigate CVE-2015-20108 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.0.0

Fixed versions

  • 1.0.0

Solution

Upgrade to version 1.0.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection')

Source file

gem/ruby-saml/CVE-2015-20108.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:51 +0000.