Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. ruby-openid
  4. ›
  5. CVE-2019-11027

CVE-2019-11027: Remotely exploitable flaw

June 10, 2019 (updated June 14, 2019)

Ruby OpenID (aka ruby-openid) has a remotely exploitable flaw. This library is used by Rails web applications to integrate with OpenID Providers. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the “example app” provided by the project are at highest risk.

References

  • github.com/openid/ruby-openid/releases/tag/v2.8.0
  • nvd.nist.gov/vuln/detail/CVE-2019-11027

Code Behaviors & Features

Detect and mitigate CVE-2019-11027 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 2.8.0

Fixed versions

  • 2.9.1

Solution

Upgrade to version 2.9.1 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

gem/ruby-openid/CVE-2019-11027.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:31 +0000.