Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. rails
  4. ›
  5. CVE-2016-0753

CVE-2016-0753: Improper Input Validation

February 16, 2016 (updated August 8, 2019)

The Rails gem supports the use of instance-level writers for class accessors, which allows remote attackers to bypass intended validation steps via crafted parameters.

References

  • nvd.nist.gov/vuln/detail/CVE-2016-0753

Code Behaviors & Features

Detect and mitigate CVE-2016-0753 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.0.0 up to 5.0.0

Fixed versions

  • 5.0.1

Solution

Upgrade to versions 5.0.1 or above.

Impact 5.3 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

gem/rails/CVE-2016-0753.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:11 +0000.