CVE-2024-53987: rails-html-sanitizer has XSS vulnerability with certain configurations
(updated )
There is a possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer 1.6.0 when used with Rails >= 7.1.0.
- Versions affected: 1.6.0
- Not affected: < 1.6.0
- Fixed versions: 1.6.1
References
- github.com/advisories/GHSA-2x5m-9ch4-qgrr
- github.com/rails/rails-html-sanitizer
- github.com/rails/rails-html-sanitizer/commit/f02ffbb8465e73920b6de0da940f5530f855965e
- github.com/rails/rails-html-sanitizer/security/advisories/GHSA-2x5m-9ch4-qgrr
- github.com/rubysec/ruby-advisory-db/blob/master/gems/rails-html-sanitizer/CVE-2024-53987.yml
- nvd.nist.gov/vuln/detail/CVE-2024-53987
Code Behaviors & Features
Detect and mitigate CVE-2024-53987 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →