Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. rails-html-sanitizer
  4. ›
  5. CVE-2022-23518

CVE-2022-23518: Improper neutralization of data URIs may allow XSS in rails-html-sanitizer

December 13, 2022 (updated November 4, 2025)

rails-html-sanitizer >= 1.0.3, < 1.4.4 is vulnerable to cross-site scripting via data URIs when used in combination with Loofah >= 2.1.0.

References

  • github.com/advisories/GHSA-mcvf-2q2m-x72m
  • github.com/rails/rails-html-sanitizer
  • github.com/rails/rails-html-sanitizer/issues/135
  • github.com/rails/rails-html-sanitizer/security/advisories/GHSA-mcvf-2q2m-x72m
  • github.com/rubysec/ruby-advisory-db/blob/master/gems/rails-html-sanitizer/CVE-2022-23518.yml
  • github.com/w3c/svgwg/issues/266
  • hackerone.com/reports/1694173
  • lists.debian.org/debian-lts-announce/2023/09/msg00012.html
  • lists.debian.org/debian-lts-announce/2024/09/msg00045.html
  • nvd.nist.gov/vuln/detail/CVE-2022-23518

Code Behaviors & Features

Detect and mitigate CVE-2022-23518 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.0.3 before 1.4.4

Fixed versions

  • 1.4.4

Solution

Upgrade to version 1.4.4 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

gem/rails-html-sanitizer/CVE-2022-23518.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:44 +0000.