Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. puppet
  4. ›
  5. CVE-2017-10689

CVE-2017-10689: Improper Privilege Management

May 13, 2022 (updated July 22, 2022)

In previous versions of Puppet Agent it was possible to install a module with world writable permissions. Puppet Agent 5.3.4 and 1.10.10 included a fix to this vulnerability.

References

  • access.redhat.com/errata/RHSA-2018:2927
  • github.com/advisories/GHSA-vw22-465p-8j5w
  • github.com/puppetlabs/puppet/commit/17d9e02da3882e44c1876e2805cf9708481715ee
  • github.com/puppetlabs/puppet/commit/2f1047f85e22cde139a421bc25d371f2ffc92cb1
  • github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2017-10689.yml
  • nvd.nist.gov/vuln/detail/CVE-2017-10689
  • puppet.com/security/cve/CVE-2017-10689
  • tickets.puppetlabs.com/browse/PUP-7866
  • usn.ubuntu.com/3567-1/

Code Behaviors & Features

Detect and mitigate CVE-2017-10689 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.10.10, all versions starting from 5.0.0 before 5.3.4

Fixed versions

  • 4.10.10
  • 5.3.4

Solution

Upgrade to versions 4.10.10, 5.3.4 or above.

Impact 5.5 MEDIUM

CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-269: Improper Privilege Management

Source file

gem/puppet/CVE-2017-10689.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:41 +0000.