Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. puppet
  4. ›
  5. CVE-2012-3866

CVE-2012-3866: Low severity vulnerability that affects puppet

October 24, 2017 (updated September 7, 2021)

lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.

References

  • lists.opensuse.org/opensuse-updates/2012-07/msg00036.html
  • puppetlabs.com/security/cve/cve-2012-3866/
  • secunia.com/advisories/50014
  • www.debian.org/security/2012/dsa-2511
  • www.ubuntu.com/usn/USN-1506-1
  • bugzilla.redhat.com/show_bug.cgi?id=839135
  • github.com/advisories/GHSA-8jxj-9r5f-w3m2
  • github.com/puppetlabs/puppet/commit/fd44bf5e6d0d360f6a493d663b653c121fa83c3f
  • nvd.nist.gov/vuln/detail/CVE-2012-3866

Code Behaviors & Features

Detect and mitigate CVE-2012-3866 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.7.0 before 2.7.18

Fixed versions

  • 2.7.18

Solution

Upgrade to version 2.7.18 or above.

Impact 2.1 LOW

AV:L/AC:L/Au:N/C:P/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-264

Source file

gem/puppet/CVE-2012-3866.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:24 +0000.