Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. publify_core
  4. ›
  5. CVE-2023-0299

CVE-2023-0299: Improper Input Validation

January 14, 2023 (updated January 23, 2023)

Improper Input Validation in GitHub repository publify/publify prior to 9.2.10.

References

  • github.com/advisories/GHSA-q3rm-f527-ghxj
  • github.com/publify/publify/commit/ca46da283572b4f8c0b5aa245008756c8a5fd1b1
  • github.com/publify/publify_core/commit/34f6e9c98e0e3b3f9896f9676b3d6442220e2b4e
  • huntr.dev/bounties/0049774b-1857-46dc-a834-f1fb15138c53
  • nvd.nist.gov/vuln/detail/CVE-2023-0299

Code Behaviors & Features

Detect and mitigate CVE-2023-0299 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 9.2.10

Fixed versions

  • 9.2.10

Solution

Upgrade to version 9.2.10 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

gem/publify_core/CVE-2023-0299.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:20 +0000.