Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. publify_core
  4. ›
  5. CVE-2022-1553

CVE-2022-1553: Incorrect Authorization

May 16, 2022 (updated May 25, 2022)

Leaking password protected articles content due to improper access control in GitHub repository publify/publify prior to 9.2.8. Attackers can leverage this vulnerability to view the contents of any password-protected article present on the publify website, compromising confidentiality and integrity of users.

References

  • github.com/publify/publify/commit/1a78f16f460847274265a12a9555b3524892d7db
  • huntr.dev/bounties/b398e4c9-6cdf-4973-ad86-da796cde221f
  • nvd.nist.gov/vuln/detail/CVE-2022-1553

Code Behaviors & Features

Detect and mitigate CVE-2022-1553 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 9.2.8

Fixed versions

  • 9.2.8

Solution

Upgrade to version 9.2.8 or above.

Impact 4.9 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

gem/publify_core/CVE-2022-1553.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:50 +0000.