Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. publify_core
  4. ›
  5. CVE-2022-0574

CVE-2022-0574: Incorrect Authorization

May 16, 2022 (updated May 24, 2022)

Improper Access Control in GitHub repository publify/publify prior to 9.2.8.

References

  • github.com/publify/publify/commit/0e6c66ac2002136517662399bca9d838c80d9739
  • huntr.dev/bounties/6f322c84-9e20-4df6-97e8-92bc271ede3f
  • nvd.nist.gov/vuln/detail/CVE-2022-0574

Code Behaviors & Features

Detect and mitigate CVE-2022-0574 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 9.2.8

Fixed versions

  • 9.2.8

Solution

Upgrade to version 9.2.8 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

gem/publify_core/CVE-2022-0574.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:14 +0000.