Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. publify_core
  4. ›
  5. CVE-2021-25973

CVE-2021-25973: Incorrect Authorization

November 2, 2021 (updated August 1, 2022)

In Publify pre1 to is vulnerable to Improper Access Control. guest role users can self-register even when the admin does not allow. This happens due to front-end restriction only.

References

  • github.com/publify/publify/commit/3447e0241e921b65f6eb1090453d8ea73e98387e
  • nvd.nist.gov/vuln/detail/CVE-2021-25973
  • www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25973

Code Behaviors & Features

Detect and mitigate CVE-2021-25973 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 9.0.0 up to 9.2.4

Fixed versions

  • 9.2.5

Solution

Upgrade to version 9.2.5 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-669: Incorrect Resource Transfer Between Spheres

Source file

gem/publify_core/CVE-2021-25973.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:24 +0000.