Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. passenger
  4. ›
  5. CVE-2015-7519

CVE-2015-7519: Header overwriting

January 8, 2016 (updated June 28, 2018)

It is possible in some cases, for clients to overwrite headers set by the server, resulting in a medium level security issue. Passenger 5 uses an SCGI-inspired format to pass headers to Ruby/Python applications, while Passenger 4 uses an SCGI-inspired format to pass headers to all applications. This implies a conversion to UPPER_CASE_WITH_UNDERSCORES whereby the difference between characters like ‘-’ and ‘_’ is lost. See “Affected use-cases” in provided link to establish wether one particular application is affected.

References

  • blog.phusion.nl/2015/12/07/cve-2015-7519/

Code Behaviors & Features

Detect and mitigate CVE-2015-7519 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.0.0a before 4.0.60, all versions starting from 5.0.0a before 5.0.22

Fixed versions

  • 4.0.60
  • 5.0.22

Solution

Upgrade to versions 4.0.60, 5.0.22 or above.

Impact 3.7 LOW

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

gem/passenger/CVE-2015-7519.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:53 +0000.