Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. omniauth-saml
  4. ›
  5. CVE-2017-11430

CVE-2017-11430: Improper Authentication

April 17, 2019 (updated October 9, 2019)

OmniAuth OmnitAuth-SAML may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing an attacker to potentially bypass authentication to SAML service providers.

References

  • nvd.nist.gov/vuln/detail/CVE-2017-11430

Code Behaviors & Features

Detect and mitigate CVE-2017-11430 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.9.0

Fixed versions

  • 1.10.0

Solution

Upgrade to version 1.10.0 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

gem/omniauth-saml/CVE-2017-11430.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:44 +0000.