Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. oauth
  4. ›
  5. CVE-2016-11086

CVE-2016-11086: Improper Certificate Validation

September 24, 2020 (updated October 5, 2020)

lib/oauth/consumer.rb in the oauth-ruby gem for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.

References

  • github.com/oauth-xx/oauth-ruby/issues/137
  • nvd.nist.gov/vuln/detail/CVE-2016-11086

Code Behaviors & Features

Detect and mitigate CVE-2016-11086 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 0.5.4

Fixed versions

  • 0.5.5

Solution

Upgrade to version 0.5.5 or above.

Impact 7.4 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-295: Improper Certificate Validation

Source file

gem/oauth/CVE-2016-11086.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:20 +0000.