Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. nokogiri
  4. ›
  5. CVE-2017-5029

CVE-2017-5029: Upstream libxslt vulnerabilities

April 24, 2017 (updated January 5, 2018)

The xsltAddTextString function in transform.c in libxslt, as used by nokogiri, lacks a check for integer overflow during a size calculation, which allows a remote attacker to perform an out-of-bounds memory write via a crafted HTML page.

References

  • www.securityfocus.com/bid/96767
  • crbug.com/676623
  • github.com/sparklemotion/nokogiri/issues/1634
  • nvd.nist.gov/vuln/detail/CVE-2017-5029

Code Behaviors & Features

Detect and mitigate CVE-2017-5029 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 1.1.29

Fixed versions

  • 1.7.1

Solution

Upgrade to version 1.7.1 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-787: Out-of-bounds Write

Source file

gem/nokogiri/CVE-2017-5029.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:55 +0000.