Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. nokogiri
  4. ›
  5. CVE-2016-4658

CVE-2016-4658: libxml2 vulnerabilities

September 25, 2016 (updated March 13, 2019)

Nokogiri is affected via its dependency libxml2. CVE-2016-4448: Format string vulnerability in libxml2 allows attackers to have unspecified impact via format string specifiers in unknown vectors. CVE-2016-4658: libxml2 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted XML document. CVE-2016-5131: libxml2 allows remote attackers to cause a denial of service or possibly have unspecified other impact via vectors related to the XPointer range-to function.

References

  • people.canonical.com/~ubuntu-security/cve/2016/CVE-2016-4448.html
  • people.canonical.com/~ubuntu-security/cve/2016/CVE-2016-4658.html
  • people.canonical.com/~ubuntu-security/cve/2016/CVE-2016-5131.html
  • github.com/sparklemotion/nokogiri/issues/1615

Code Behaviors & Features

Detect and mitigate CVE-2016-4658 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.7.1

Fixed versions

  • 1.7.1

Solution

Upgrade to version 1.7.1 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-119: Improper Restriction of Operations within the Bounds of a Memory Buffer

Source file

gem/nokogiri/CVE-2016-4658.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:44 +0000.