Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. loofah
  4. ›
  5. CVE-2022-23515

CVE-2022-23515: Improper neutralization of data URIs may allow XSS in Loofah

December 13, 2022 (updated November 4, 2025)

Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs.

References

  • github.com/advisories/GHSA-228g-948r-83gx
  • github.com/flavorjones/loofah
  • github.com/flavorjones/loofah/commit/415677f3cf7f9254f42f811e784985cd63c7407f
  • github.com/flavorjones/loofah/issues/101
  • github.com/flavorjones/loofah/security/advisories/GHSA-228g-948r-83gx
  • github.com/rubysec/ruby-advisory-db/blob/master/gems/loofah/CVE-2022-23515.yml
  • github.com/w3c/svgwg/issues/266
  • hackerone.com/reports/1694173
  • lists.debian.org/debian-lts-announce/2023/09/msg00011.html
  • lists.debian.org/debian-lts-announce/2024/09/msg00044.html
  • nvd.nist.gov/vuln/detail/CVE-2022-23515

Code Behaviors & Features

Detect and mitigate CVE-2022-23515 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.1.0 before 2.19.1

Fixed versions

  • 2.19.1

Solution

Upgrade to version 2.19.1 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

gem/loofah/CVE-2022-23515.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:11 +0000.