Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. json
  4. ›
  5. CVE-2025-27788

CVE-2025-27788: Out-of-bounds Read in Ruby JSON Parser

March 12, 2025 (updated March 13, 2025)

A specially crafted document could cause an out of bound read, most likely resulting in a crash.

Versions 2.10.0 and 2.10.1 are impacted. Older versions are not.

References

  • github.com/advisories/GHSA-9m3q-rhmv-5q44
  • github.com/ruby/json
  • github.com/ruby/json/commit/c56db31f800d5d508389793e69682f99749dbadf
  • github.com/ruby/json/releases/tag/v2.10.2
  • github.com/ruby/json/security/advisories/GHSA-9m3q-rhmv-5q44
  • github.com/rubysec/ruby-advisory-db/blob/master/gems/json/CVE-2025-27788.yml
  • nvd.nist.gov/vuln/detail/CVE-2025-27788

Code Behaviors & Features

Detect and mitigate CVE-2025-27788 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.10.0 before 2.10.2

Fixed versions

  • 2.10.2

Solution

Upgrade to version 2.10.2 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-125: Out-of-bounds Read

Source file

gem/json/CVE-2025-27788.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:16 +0000.