Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. json-jwt
  4. ›
  5. CVE-2019-18848

CVE-2019-18848: Improper Input Validation

November 12, 2019 (updated November 14, 2019)

The json-jwt gem before for Ruby lacks an element count during the splitting of a JWE string.

References

  • nvd.nist.gov/vuln/detail/CVE-2019-18848

Code Behaviors & Features

Detect and mitigate CVE-2019-18848 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.11.0

Fixed versions

  • 1.11.0

Solution

Upgrade to version 1.11.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

gem/json-jwt/CVE-2019-18848.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:54 +0000.