Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. gollum-lib
  4. ›
  5. CVE-2014-9489

CVE-2014-9489: Improper Access Control

November 16, 2017 (updated September 16, 2021)

The gollum-grit_adapter Ruby gem dependency in gollum and the gollum-lib gem dependency in gollum-lib when the string “master” is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or –open-files-in-pager flags.

References

  • www.openwall.com/lists/oss-security/2015/01/03/19
  • www.securityfocus.com/bid/71499
  • github.com/advisories/GHSA-q97v-764g-r2rp
  • github.com/gollum/gollum/issues/913
  • github.com/gollum/grit_adapter/commit/4520d973c81fecfebbeacd2ef2f1849d763951c7
  • nvd.nist.gov/vuln/detail/CVE-2014-9489

Code Behaviors & Features

Detect and mitigate CVE-2014-9489 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.0.1

Fixed versions

  • 4.0.1

Solution

Upgrade to version 4.0.1 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-284: Improper Access Control
  • CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Source file

gem/gollum-lib/CVE-2014-9489.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:12 +0000.