Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. geokit-rails
  4. ›
  5. CVE-2023-26153

CVE-2023-26153: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

October 6, 2023 (updated November 7, 2023)

Versions of the package geokit-rails before 2.5.0 is vulnerable to Command Injection due to unsafe deserialisation of YAML within the ‘geo_location’ cookie. This issue can be exploited remotely via a malicious cookie value. Note: An attacker can use this vulnerability to execute commands on the host system.

References

  • gist.github.com/CalumHutton/b7aa1c2e71c8d4386463ac14f686901d
  • github.com/advisories/GHSA-7xvc-v44j-46fh
  • github.com/geokit/geokit-rails/blob/master/lib/geokit-rails/ip_geocode_lookup.rb
  • github.com/geokit/geokit-rails/commit/7ffc5813e57f6f417987043e1039925fd0865c43
  • github.com/geokit/geokit-rails/commit/a93dfe49fb9aeae7164e2f8c4041450a04b5482f
  • github.com/rubysec/ruby-advisory-db/blob/master/gems/geokit-rails/CVE-2023-26153.yml
  • nvd.nist.gov/vuln/detail/CVE-2023-26153
  • security.snyk.io/vuln/SNYK-RUBY-GEOKITRAILS-5920323

Code Behaviors & Features

Detect and mitigate CVE-2023-26153 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.5.0

Fixed versions

  • 2.5.0

Solution

Upgrade to version 2.5.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data

Source file

gem/geokit-rails/CVE-2023-26153.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:54 +0000.