Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. foreman_fog_proxmox
  4. ›
  5. CVE-2021-20259

CVE-2021-20259: Exposure of Sensitive Information to an Unauthorized Actor

June 7, 2021 (updated June 15, 2021)

A flaw was found in the Foreman project. The Proxmox compute resource exposes the password through the API to an authenticated local attacker with view_hosts permission. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. Versions before foreman_fog_proxmox are affected

References

  • bugzilla.redhat.com/show_bug.cgi?id=1932144
  • nvd.nist.gov/vuln/detail/CVE-2021-20259

Code Behaviors & Features

Detect and mitigate CVE-2021-20259 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.13.1

Fixed versions

  • 0.13.1

Solution

Upgrade to version 0.13.1 or above.

Impact 7.8 HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Source file

gem/foreman_fog_proxmox/CVE-2021-20259.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:54 +0000.