Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. fluentd
  4. ›
  5. CVE-2026-44160

CVE-2026-44160: Fluentd is Vulnerable to Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`

June 26, 2026

Fluentd’s in_http and in_forward plugins support receiving gzip-compressed data. While Fluentd correctly enforces size limits on the incoming compressed payloads (e.g., via body_size_limit or chunk_size_limit), it was discovered that there is no limit enforced on the size of the decompressed data.

If a Fluentd instance is exposed to untrusted networks, an attacker can send a maliciously crafted, highly compressed payload. When Fluentd attempts to decompress this payload in memory, it will expand to an excessive size, completely bypassing the intended payload size limits.

References

  • github.com/advisories/GHSA-j9cw-hwqf-85w7
  • github.com/fluent/fluentd/releases/tag/v1.19.3
  • github.com/fluent/fluentd/security/advisories/GHSA-j9cw-hwqf-85w7
  • nvd.nist.gov/vuln/detail/CVE-2026-44160

Code Behaviors & Features

Detect and mitigate CVE-2026-44160 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.19.3

Fixed versions

  • 1.19.3

Solution

Upgrade to version 1.19.3 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-409: Improper Handling of Highly Compressed Data (Data Amplification)

Source file

gem/fluentd/CVE-2026-44160.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:04 +0000.