Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. espeak-ruby
  4. ›
  5. CVE-2016-10193

CVE-2016-10193: Remote Code Execution Vulnerability

March 3, 2017 (updated March 8, 2017)

The gem passes user modifiable strings directly to a shell command. An attacker can execute malicious commands by modifying the strings that are passed as arguments to the speak, save, bytes and bytes_wav methods in the lib/espeak/speech.rb library.

References

  • github.com/dejan/espeak-ruby/issues/7

Code Behaviors & Features

Detect and mitigate CVE-2016-10193 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.0.3

Fixed versions

  • 1.0.3

Solution

Upgrade to version 1.0.3 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-284: Improper Access Control

Source file

gem/espeak-ruby/CVE-2016-10193.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.