Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. elastic-apm
  4. ›
  5. CVE-2019-7615

CVE-2019-7615: Improper Certificate Validation

May 24, 2022 (updated March 3, 2023)

A TLS certificate validation flaw was found in Elastic APM agent for Ruby versions before 2.9.0. When specifying a trusted server CA certificate via the ‘server_ca_cert’ setting, the Ruby agent would not properly verify the certificate returned by the APM server. This could result in a man in the middle style attack against the Ruby agent.

References

  • github.com/advisories/GHSA-35j2-p8fh-x966
  • github.com/elastic/apm-agent-ruby/pull/449
  • nvd.nist.gov/vuln/detail/CVE-2019-7615
  • www.elastic.co/community/security/

Code Behaviors & Features

Detect and mitigate CVE-2019-7615 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.9.0

Fixed versions

  • 2.9.0

Solution

Upgrade to version 2.9.0 or above.

Impact 7.4 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-295: Improper Certificate Validation

Source file

gem/elastic-apm/CVE-2019-7615.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:03 +0000.