Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. cocoapods-downloader
  4. ›
  5. CVE-2022-24440

CVE-2022-24440: Command injection

April 2, 2022 (updated April 5, 2022)

The package cocoapods-downloader before 1.6.0, from 1.6.2 and before 1.6.3 is vulnerable to Command Injection via git argument injection. When calling the Pod::Downloader.preprocess_options function and using git, both the git and branch parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.

References

  • github.com/CocoaPods/cocoapods-downloader/pull/124
  • github.com/CocoaPods/cocoapods-downloader/pull/128
  • github.com/advisories/GHSA-7627-mp87-jf6q
  • nvd.nist.gov/vuln/detail/CVE-2022-24440
  • snyk.io/vuln/SNYK-RUBY-COCOAPODSDOWNLOADER-2414278

Code Behaviors & Features

Detect and mitigate CVE-2022-24440 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.6.0, all versions starting from 1.6.2 before 1.6.3

Fixed versions

  • 1.6.0
  • 1.6.3

Solution

Upgrade to versions 1.6.0, 1.6.3 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')

Source file

gem/cocoapods-downloader/CVE-2022-24440.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:59 +0000.