Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. cocoapods-downloader
  4. ›
  5. CVE-2022-21223

CVE-2022-21223: Command Injection

April 2, 2022 (updated April 5, 2022)

The package cocoapods-downloader before 1.6.2 is vulnerable to Command Injection via hg argument injection. When calling the download function (when using hg), the url (and/or revision, tag, branch) is passed to the hg clone command in a way that additional flags can be set. The additional flags can be used to perform a command injection.

References

  • github.com/CocoaPods/cocoapods-downloader/pull/127
  • github.com/advisories/GHSA-g397-v4w5-4m79
  • nvd.nist.gov/vuln/detail/CVE-2022-21223
  • snyk.io/vuln/SNYK-RUBY-COCOAPODSDOWNLOADER-2414280

Code Behaviors & Features

Detect and mitigate CVE-2022-21223 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.6.2

Fixed versions

  • 1.6.2

Solution

Upgrade to version 1.6.2 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')

Source file

gem/cocoapods-downloader/CVE-2022-21223.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.