Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. carrierwave
  4. ›
  5. CVE-2021-21305

CVE-2021-21305: Injection Vulnerability

February 8, 2021 (updated April 26, 2022)

In CarrierWave, there is a code injection vulnerability. Attackers can craft a string that can be executed as a Ruby code.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-21305

Code Behaviors & Features

Detect and mitigate CVE-2021-21305 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.3.2, all versions starting from 2.0.1 before 2.1.1

Fixed versions

  • 1.3.2
  • 2.1.1

Solution

Upgrade to versions 1.3.2, 2.1.1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

gem/carrierwave/CVE-2021-21305.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:17 +0000.