Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. bundler
  4. ›
  5. CVE-2020-36327

CVE-2020-36327: Dependency Confusion

April 29, 2021 (updated July 30, 2021)

Bundler sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application.

References

  • bundler.io/blog/2021/02/15/a-more-secure-bundler-we-fixed-our-source-priorities.html
  • msrc.microsoft.com/update-guide/en-US/vulnerability/CVE-2021-24105
  • nvd.nist.gov/vuln/detail/CVE-2020-36327

Code Behaviors & Features

Detect and mitigate CVE-2020-36327 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.16.0 before 2.2.16

Fixed versions

  • 2.2.16

Solution

Upgrade to version 2.2.16 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

gem/bundler/CVE-2020-36327.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:46 +0000.