Advisory Database
  • Advisories
  • Dependency Scanning
  1. conan
  2. ›
  3. wolfssl
  4. ›
  5. CVE-2022-25640

CVE-2022-25640: Improper Authentication

February 24, 2022 (updated August 8, 2023)

In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.

References

  • github.com/wolfSSL/wolfssl/pull/4831
  • nvd.nist.gov/vuln/detail/CVE-2022-25640

Code Behaviors & Features

Detect and mitigate CVE-2022-25640 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.2.0

Fixed versions

  • 5.2.0

Solution

Upgrade to version 5.2.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-295: Improper Certificate Validation

Source file

conan/wolfssl/CVE-2022-25640.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.