Advisory Database
  • Advisories
  • Dependency Scanning
  1. conan
  2. ›
  3. wolfssl
  4. ›
  5. CVE-2022-25638

CVE-2022-25638: Improper Certificate Validation

February 24, 2022 (updated March 4, 2022)

In wolfSSL before 5.2.0, certificate validation may be bypassed during attempted authentication by a TLS 1.3 client to a TLS 1.3 server. This occurs when the sig_algo field differs between the certificate_verify message and the certificate message.

References

  • github.com/wolfSSL/wolfssl/pull/4813
  • nvd.nist.gov/vuln/detail/CVE-2022-25638
  • www.wolfssl.com/docs/security-vulnerabilities/

Code Behaviors & Features

Detect and mitigate CVE-2022-25638 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.2.0

Fixed versions

  • 5.2.0

Solution

Upgrade to version 5.2.0 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-295: Improper Certificate Validation

Source file

conan/wolfssl/CVE-2022-25638.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:33 +0000.