Advisory Database
  • Advisories
  • Dependency Scanning
  1. conan
  2. ›
  3. wolfssl
  4. ›
  5. CVE-2022-23408

CVE-2022-23408: Use of Insufficiently Random Values

January 18, 2022 (updated January 27, 2022)

wolfSSL uses non-random IV values in certain situations. This affects connections (without AEAD) using AES-CBC or DES3 with TLS or DTLS This occurs because of misplaced memory initialization in BuildMessage in internal.c.

References

  • github.com/wolfSSL/wolfssl/blob/master/ChangeLog.md
  • github.com/wolfSSL/wolfssl/pull/4710
  • nvd.nist.gov/vuln/detail/CVE-2022-23408

Code Behaviors & Features

Detect and mitigate CVE-2022-23408 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 5.0.0 before 5.1.1

Fixed versions

  • 5.1.1

Solution

Upgrade to version 5.1.1 or above.

Impact 9.1 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-330: Use of Insufficiently Random Values

Source file

conan/wolfssl/CVE-2022-23408.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:23 +0000.